Support

2 Support Entries

Problem:

  • Welding process starts but no welding current.

Possible Causes & Resolutions:

  • Condition of lower welding roll: Possibly the roll is worn out or mercury very old. Refill mercury or exchange lower welding roll.
  • Condition of upper roller head: Possibly the roller head is worn out or mercury very old. Refill mercury or exchange upper roller head.
  • Waterflow: The green button for welding current on/off must light up when the water flow is ok. If not maybe the water flow is to low. Check also the relay K21. If water flow is ok this relay has to be on.
  • Welding pressure switch S31: If welding rolls are closed the switch S31 do enable the welding current. If the welding pressure is adjusted to low or also to high the control do not enable the current. Do adjust the welding pressure correctly according manual.
  • All connections of current conductors on secondary side of welding transformer: All screws must be tightened. If there are signs of corrosion, disassemble parts and clean the contact surfaces.
  • Connection between head piece and lower welding arm: Remove the head piece and check the contact surfaces.

 

  • Fine-wire fuses F2, F3 and F4: This are located inside control. Check them with ohm meter and replace if necessary.
  • Transformer T4 (18-0-18V): Measure the outputs of small transformer inside control. The easiest way to do this is to measure it at the terminals of the WEC card. c32/c30 => 18VAC, c32/c28 => 18VAC, c28/c30 => 36VAC
  • WEC electronic card: Firmly inserted in the card holder?
  • Thyristor: Maybe thyristor module is broken.

If the welding phases are wrong, then the welding current is probably loaded only by one phase!

Phase L1 and L2 (yellow & orange > see Elec Scheme L1 must be used to supply:

  • 18/0/18 VAC transformer and electronic print type WEC
  • Thyristor and welding transformer